Массовый взлом сайтов на Битриксе

Во вторник, 28 июня, владельцы порталов и сайтов на Битриксе столкнулись с массовым взломом своих проектов. Из обсуждения на официальном форуме Битрикса известно, что злоумышленникам удалось получить полный доступ к множеству сайтов на базе этой CMS — вплоть до смены всех паролей и удаления данных.
dev.1c-bitrix.ru/community/forums/forum6/topic147346/

Предполагаем, что для осуществления взлома злоумышленники использовали несколько путей, в том числе:
  • через уязвимость модуля vote (версия ниже 21.0.100). Уязвимость позволяет нарушителям воспользоваться возможностью отправки специально сформированных сетевых пакетов и записывать произвольные файлы в систему;
  • через встроенный редактор html.
Если у вас есть проекты на Битриксе, рекомендуем обновить CMS до последней версии. В версии 21.0.1 модуля vote уже исправлены ошибки безопасности. Также советуем проверить наличие корректных резервных копий сайтов.
dev.1c-bitrix.ru/docs/versions.php?lang=ru&module=vote

Если у вас нет бэкапов, не откладывайте их создание. Дополнительно до выяснения подробностей об уязвимости рекомендуем в файлах /bitrix/tools/vote/uf.php и /bitrix/tools/html_editor_action.php перед require_once вставить следующий код:
if ($_SERVER['REQUEST_METHOD'] === 'POST') 

{          

    header("Status: 404 Not Found");

    die();

}

При возникновении вопросов или проблем с доступностью сайтов на Битриксе вы можете обратиться к специалистам техподдержки в Личном кабинете.

0 комментариев

Оставить комментарий