OVH – Spectre Variant 4 and 3a disclosure

Наряду с остальной частью ИТ-индустрии OVH был осведомлен о некоторых конкретных уязвимостях безопасности («Spectre variant 4» и «Spectre Variant 3a») в отношении некоторых процессорных архитектур, влияющих на продукты Intel, но, возможно, других поставщиков процессоров. Две из этих уязвимостей позволяют выполнять атаки побочных каналов на основе того же механизма, что и предыдущая уязвимость, описанная в январе 2018 года под названием «Spectre» (CVE-2017-5753 и CVE-2017-5715).


Эти уязвимости являются вариантами «Spectre» и называются «Spectre Variant 3a» (CVE-2018-3640) и «Spectre Variant 4» (CVE-2018-3639), оба они также известны как «SpectreNG» или «Spectre New Generation» ». Специфический «Spectre Variant 4» также упоминается как «Спекулятивный шлейф магазина».

Хотя они тесно связаны с «Spectre», у них достаточно разницы, чтобы считаться определенными недостатками, которые потребуют дополнительных действий для определенных архитектур процессора.

Spectre Variant 3a касается систем с микропроцессорами, использующих спекулятивное выполнение и выполняющих спекулятивные чтения системных регистров, что может позволить несанкционированное раскрытие системных параметров злоумышленнику с локальным доступом пользователя через анализ побочных каналов.

Spectre Variant 4 относится к системам с микропроцессорами, использующими спекулятивное выполнение и спекулятивное выполнение считывания памяти до того, как будут известны адреса всех предыдущих записей в памяти, что может позволить несанкционированное раскрытие информации злоумышленнику с локальным доступом пользователя через анализ побочных каналов.

Мы также знаем, что Spectre Variant 4 может выполняться в среде исполнения на языке. Наиболее частое использование среды выполнения — это JavaScript, который используется в веб-браузерах, но в настоящее время мы не знаем о успешной эксплуатации веб-браузера.

Узнав об этих уязвимостях, OVH немедленно мобилизовала свои команды, чтобы четко понимать последствия этих недостатков, оценивать риски и разрабатывать план действий по защите своих инфраструктур, а также определять лучший курс действий для своих клиентов.

Мы будем сообщать в ближайшие часы список всех заинтересованных продуктов и услуг OVH с относительными действиями, начатыми и запланированными OVH, а также действиями, которые необходимы сторонам для защиты своих инфраструктур.

Смягчение этих недостатков потребует добавления микрокода процессора и обновлений программного обеспечения / операционной системы. Как обычно, мы будем продолжать тестировать каждый микрокод или разумное обновление внутри, прежде чем развертывать что-либо вживую, чтобы обеспечить безопасность и стабильность инфраструктуры наших клиентов.

С точки зрения SysAdmin мы также настоятельно рекомендуем отслеживать обновления операционной системы и гипервизора, а также поддерживать современные системы тезисов.

Для отдельных клиентов мы напоминаем, что с января 2018 года все основные веб-браузеры были исправлены, чтобы смягчить Spectre Variant 1 в их управляемых средах. Эти исправления затрудняют использование атак на боковых каналах через веб-браузер, и мы можем предположить, что эти патчи в некоторой степени могут быть применимы к варианту 4. При наличии текущего уровня информации OVH настоятельно призывает своих отдельных клиентов и общественность для проверки и сохранения их веб-браузера (ов) в актуальном состоянии.

В более глобальном плане мы активно и тесно сотрудничаем с Intel, нашими партнерами и производителями по этой теме, и в настоящее время мы изучаем потенциальные риски, связанные с этими недостатками. Мы будем информировать вас в режиме реального времени о любой полученной нами информации и будем применять любые возможные меры безопасности для соответствующих служб.

Как всегда, мы также будем информировать наших клиентов и общественность о любых корректирующих действиях, которые требуются на их стороне, чтобы уменьшить их воздействие на машины и / или инфраструктуру.

0 комментариев

Оставить комментарий